Айрона
03.04.2023 01:04

Написать программу на языке с++ с циклом do while вычислить сумму членов ряда с точностью е=10^-2 при заданном х=0.75. s=7.5-lnx^3/2! +lnx^5/4! я нашла для этого примера общий вид (прикреплю в фото) ❗❗❗❗❗ мне нужно расписать именно этот общий вид на языке с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alyonkakingAlyonka76
09.06.2020 06:09

Объяснение:

Похоже, что ряд, который показан на первом фото, не сходится.

Я написал код для ряда на втором фото

#include <stdio.h>

#include <iostream>

#include <cmath>

using namespace std;

const double EPS = 1e-2; // epsilon - точность вычисления суммы

const double X = 0.75; // x - аргумент, значение функции которого надо вычислить

double MySum(double X, double EPS)

{

double s = 0;// Тут копим сумму

double an; // Тут храним N-ый член ряда

int n; // счётчик

n = 1; // начальное значение n

an = 0; // начальное значение an

do {

 an = pow(-1, n + 2) * 2 / ((2 * n + 1)*log(X));

 s += an; // суммируем очередной член ряда

 n++; // переходим к следующему члену

} while (fabs(an) > EPS); // Суммировать будем пока член ряда an не станет достаточно маленьким по модулю

return s; // получившаяся сумма

}

int main()

{

setlocale(LC_ALL, "RUS");

cout <<"Сумма ряда с точностью до " << EPS << "= " << MySum(X, EPS) << endl;

system("pause");

return 0;

}

Если появятся вопросы смело обращайтесь

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота