Вставьте пропущенные фрагменты в программу на языке Паскаль.
Составить программу перевода целого положительного числа, которое вводится с клавиатуры, из восьмеричной системы счисления в десятичную систему счисления.
Program Primer;
var d, i, n, c, e:integer; s: ( 1. integer; 2. real; 3. string;)
begin
1. readln(d); 2. readln (n); 3. readln (s);
d:=0; n:=1;
1. for i:=1 downto length(s) do
2. for i:=1 to length(s) do
3. for i:=length(s) downto 1 do
4. for i:=length(s) to 1 do
begin
1.val (s, [i], c, e)
2. length (s, [i], c, e)
3. str (s, [i], c, e)
4. div (s, [i], c, e)
5. sqr (s, [i], c, e)
6. abs (s, [i], c, e)
7. mod (s, [i], c, e)
d:=
1. d+c*c;
2. c-d*n;
3. d-c*n;
4. c+d*n;
5. d-c*c
6. d+c*n
n:=
1. n+8;
2. n*8;
3. n-8;
4. n/8;
end;
1. writeln (s)
2. writeln (d)
3. writeln (n)
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
debnatkh
19.05.2020 16:30

Проверенные ответы содержат информацию, которая заслуживает доверия. На «Знаниях» вы найдёте миллионы решений, отмеченных самими пользователями как лучшие, но только проверка ответа нашими экспертами даёт гарантию его правильности.

{Задача сделана на языке паскаль, при Оформление сделана как для студенческой задачи

Если есть во пиши в личку

Задача:Написать программу на языке программирования Pascal, которая вводит с клавиатуры 4 числа и выводит результат вычисления спо следующей схеме: "число1"−"число2"/"число3"+"число4"

Автор:

Дата:  }

 var  x1, x2, x3, x4: integer;

f:real;

begin

//Ввод

writeln('введите 1 число');

readln(x1);  

writeln('введите 2 число');

readln(x2);  

writeln('введите 3 число');

readln(x3);  

writeln('введите 4 число');

readln(x4); //решение

f:=(x1-x2)/(x3+x4);  

//вывод

writeln (f);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота