Vlad29rus228999
10.05.2023 01:20

Написать программу: дана число, если оно меньше 15, то нарисовать 100 эллипсов, иначе 100 линий

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ilka2004z
05.03.2020 16:18

var

 x: real;  

 cost: real;  //Стоимость капитала

 i: integer;

 

begin

 cost:= 20;  //Начальная стоимость равна 20  

 writeln('Введите ежегодный прирост в процентах');

 readln(x);  //Вводим ежегодный прирост в процентах

 for i:= 1626 to 2012 do   {Каждый год стоимость капитала увеличивается на стоимость капитала * х / 100}

   cost:= cost + cost * (x / 100);

 writeln('Стоимость капитала составляла бы в этом году:  ', cost : 0 : 5, ' $');  {Выводим стоимость капитала с округлением до 5 знаков после запятой}

end.  

Отметь решение как лучшее)

Объяснение:

0,0(0 оценок)
Ответ:
infernalcookie
17.05.2022 05:08

ответ: Код можете скопировать в обьяснении. Вроде как сделал, но с недороботками. Вот, что нужно поправить:

- Проверить дату рождения на существование (например, если человек ввел будущую дату или там 31 апреля)

- 3ий пункт : может выдавать отрицательные числа, это тоже нужно доработать.

Объяснение:

from datetime import *

# Описание программы

print('\t' * 2, 'Компьютерная система')

print('\t' * 1, '(анализирует дату рождения человек по разным критериям)')

print('=' * 46)

# Меню

print('Меню')

print('[1]- год рождения(высокосный/обычный)',

     '\n[2]-возрастная група', '\n[3]-точный возраст')

print('=' * 46)

print("\nУкажите свою дату рождения")

d = int(input("День: "))  # День

m = int(input("Месяц: "))  # Месяц

y = int(input("Год: "))  # Год

print("\nСегодняшняя дата:", datetime.today().strftime("%d.%m.%Y"))

c = int(input("Выберите то, что Вы хотите: "))

if c == 1:  # Определение типа года

   if y % 4 != 0 or (y % 100 == 0 and y % 400 != 0):

       print("Это обычный год (365 дней)")

   else:

       print("Это високосный год (366 дней)")

elif c == 2:  # Определение возрастной группы

   age = datetime.now().year - y

   if age >= 0 and age <= 6:

       print("Ваша группа: Дошкольник")

   elif age >= 7 and age <= 17:

       print("Ваша группа: Школьник")

   elif age >= 18 and age <= 18:

       print("Ваша группа:  Молодежь")

   elif age >= 31 and age <= 55:

       print("Ваша группа: Взрослый")

   elif age >= 56:

       print("Ваша группа: Пожилой/Старый")

elif c == 3:

   print("Ваш возраст:", datetime.now().year - y, "лет,",

         datetime.now().month - m, "месяц,", datetime.now().day - d, "день")


написать код продолжить. Это как мини-магазин.Что бы можно было в нем что-то делать. компьютерный ас
написать код продолжить. Это как мини-магазин.Что бы можно было в нем что-то делать. компьютерный ас
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота