NoName2op
01.03.2023 04:24

Написать программу, которая определяет числу,введенному с клавиатуры его абсолютную величину (модуль) не используя команду abs(x). (Например: вводят число "-9", программа выдает "9", или вводят "2" и выводится "2.").

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
0p3n
15.10.2020 00:25

C++

#include <iostream>

using namespace std;

int main()

{

int number = 1;

cout << "Input number - ";

cin >> number;

cout << endl;

int abs = 0;

number < 0 ? abs = -number : abs = number;

cout << "Abs(" << abs << ")" << endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота