Lesha152
12.04.2022 20:23

Дана квадратная матрица размерностью n*n. Написать программу формирования последовательности А, элементами которой являются элементы таблицы В, расположенные над второстепенной диагональю. В полученной последовательности найти три наибольших элемента. Если количество элементов между 2-м и 3-м элементами совпадает с количеством элементов между 1-м и 2-м элементами, то поменять их местами, сохранив порядок следования (без использования дополнительного массива). Преобразованный массив вывести на экран и в файл.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
YNWA12
19.05.2023 11:08
1) Множество - Кирпич {Белый, Красный, Огнеупорный} Величины {вес, масса, прочность}  
2) Изучить объект, сопоставить полученные данные со знаниями об этом мире (предыдущим жизненным опытом), руководствуясь здравой логикой определить гипотезы и провести эксперименты, получить результаты, проанализировать и сделать выводы о свойствах.
3) Список значков, ярлыков, фон рабочего стола, расстояние между значками, их шрифт и размер
4) я так понимаю глагол - сделать, опечатка, ответ - переименовать поместить файл в папку, удалить, изменить файловые атрибуты файловой системы, задать квоты доступа
0,0(0 оценок)
Ответ:
hitman1790
07.05.2023 11:20
Var
  s1, s2: string;
  i, n: integer;

begin
  Write('Введите слово: ');
  Readln(s1);
  n := Length(s1);
  i := n div 2;
  s2 := Copy(s1, i + 1, n - i) + Copy(s1, 1, i);
  Writeln('А вот перестановка его частей: ', s2)
end.

Тестовое решение:
Введите слово: тестирование
А вот перестановка его частей: ованиетестир

var
  s: string;
  i, n, c1, c2, c3, c4: integer;

begin
  Write('Введите строку: ');
  Readln(s);
  n := Length(s);
  c1 := 0; c2 := 0; c3 := 0; c4 := 0;
  for i := 1 to n do
    case s[i] of
      '*': c1 := c1 + 1;
      'D': c2 := c2 + 1;
      'F': c3 := c3 + 1;
      'H': c4 := c4 + 1
    end;
  Writeln('В строке встретилось следующее количество символов:');
  Writeln('*-', c1, ', D-', c2, ' F-', c3, ' H-', c4)
end.

Тестовое решение:
Введите строку: WHY DO YOU CRY, WILLI, WHY DO YOU CRY?
В строке встретилось следующее количество символов:
*-0, D-2 F-0 H-2

const
  digits = ['0', '1', '2', '3', '4', '5', '6', '7', '8', '9'];

var
  s1, s2: string;
  i, n: integer;

begin
  Write('Введите строку: ');
  Readln(s1);
  n := Length(s1);
  s2 := '';
  for i := 1 to n do
    if not (s1[i] in digits) then
      s2 := s2 + s1[i];
  s1 := s2;
  Writeln('Строка с исключенными цифрами: ', s1);
end.

Тестовое решение:
Введите строку: Сегодня в 14:52 я получил сообщение, что телепередача в 21:50 не будет интересной.
Строка с исключенными цифрами: Сегодня в : я получил сообщение, что телепередача в : не будет интересной.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота