liliannaklochko
10.12.2022 00:47

Составьте программу вычисления среднеарифметического значения для побочной диагонали. Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Pilulkin112
19.05.2023 09:08

Если квадратов десять, то:

 

[если честно, лет 7 не кодил на паскале, поэтому могу ошибаться в синтаксисе или каких-то деталях]

задаем 3 массива числовых элементов:

var

S, P, x: array[1..10] of integer; //S - будущие площади, P - периметры, x - стороны квадратов

i: integer; //счетчик для цикла

 

begin

for i := 1 to 10 do

 begin

  Writeln("Введите сторону "+IntToStr(i)+" квадрата:");

  Readln(x[i]);

 end; //ввели стороны, теперь вычисляем площади и периметры:

 

for i := 1 to 10 do

 begin

  S[i] := x[i]*x[i]; //для нахождения площади перемножаем стороны каждого квадрата

  P[i] := x[i]*4; //для нахождения периметра - умножаем сторону квадрата на 4

//и тут же выводим это на экран:

  Writeln("Площадь "+IntToStr(i)+" квадрата равна "+IntToStr(S[i]));

  Writeln("Периметр "+IntToStr(i)+" квадрата равен "+IntToStr(P[i]));

  Writeln;

 end;

 

Readln //это чтоб дождаться нажатия Энтер перед закрытием окошка :)

end;

 

Должно работать.

0,0(0 оценок)
Ответ:
yasasmail
04.02.2021 17:12
Задание 1

Нам нужно найти наибольшее число x, при котором данное выражение ложно. Когда оно вообще ложно?

В данном логическом выражении используется дизъюнкция (ИЛИ), которая ложна только в одном случае - это когда оба выражения ложны. Когда же выражения ложны? Рассмотрим же их. В обоих выражениях фигурирует отрицание. То есть, выражение в скобках должны быть истинным. Объясняю:

НЕ (истина) = ложь

А это значит, что условие (x < 10) и (число чётное) должны выполняться. Нам нужно найти наибольшее чётное число. Это не может быть 10, поскольку знак неравенства строгий, следовательно, ближайшее наибольшее чётное число - это 8.

ответ

8

Задание 2

Для данного выражения требуется выполнение следующих условий:

НЕ (x < 7) должно быть ложным, то есть (x < 7) должно быть истинным(x < 6) должно быть ложным

Второе выражение мы можем преобразовать так:

(x ≥ 6). Почему 6 включительно? Потому что, подставив шестёрку в исходное выражение получим: 6 < 6 - ложь. Итого наше выражение имеет вид:

НЕ (x < 7) или (x ≥ 6). Нужно найти наибольшее число, при котором выражение ложно. Это число: 6.

ответ

6

Задание 3

Такое же, как и 2

Задание 4

Решается абсолютно также, как и 2. Дизъюнкция - значит в обеих частях выражения должна быть ложь. Когда ложь получается в двух выражениях? Рассмотрим эти случаи:

НЕ (x < 6) ложно тогда, когда (x < 6) истинно(x < 5) ложно тогда, когда (x ≥ 5)

Итого:

НЕ (x < 6) ИЛИ (x ≥ 5)

ответ

5

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота