Maksim55666
09.05.2023 22:59

Написать программу, которая определяет будут ли корни квадратного уравнения по введенным с клавиатуры коофициентам

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Barsvtk
08.04.2023 03:50

За частую искусственный интеллект построен на определенной математической модели с некоторого языка программирования(информатика). Изначально ИИ ничего не умеет и для этого его нужно чему то обучить. Процесс обучения называется - машинным обучением. Машинное обучение происходит на уровне физики так как это наука про самое элементарное и так же можно описать большинство физических процессов. Сама биология и физика понадобиться уже в дальнейшем для определенного рода ИИ. Так как поведение ИИ зависит от его предназначения. К примеру можно взять ИИ для распознавания онкопатологий по результатам комп'ютерной томографии (Его нужно будет обучать на уровне биологии, что бы он более качественно и правильно распознавал опухоли) в зависимости от глубины проникновения рентгеновских лучей в аппарате.

0,0(0 оценок)
Ответ:
allahgulievaru
25.02.2020 13:57

program z1;

var a:array [1..10] of integer;

i,max,min:integer;

begin

for i:=1 to 10 do

begin

write('Введите ',i:2,' элемент: ');

readln(a[i])

end;

writeln;

max:=a[1];

min:=a[1];

for i:=2 to 10 do

begin

if a[i]>max then max:=a[i];

if a[i]<min then min:=a[i]

end;

writeln ('Максимальное число: ',max);

writeln (' Минимальное число: ',min);

end.

Объяснение:

Ввод элементов массива с пояснениями

Присваиваем переменным для максимального и минимального числа значение 1-го элемента

Сравнение остальных элементов массива с переменными для максимального и минимального, при необходимости присваивание этим переменным новых значений

Вывод максимального и минимального числа

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота