arrow34
18.12.2022 21:12

На питон Создайте класс Circle, который опишете тремя свойствами: координаты точки центра и радиус. Опишите конструктор класса. Опишите метод, вычисляющий площадь окружности. Напишите программу, в которой введите данные об n окружностях. Выведите информацию о созданных окружностях и их длинах.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aizhanashoznweb
22.04.2021 08:09
1) есть некоторые знаки которые нельзя использовать в имени файла, это знаки маски например такие как "? *" и знаки что используются в системе каталогов например ": \". При попытке создать файл с неправильными знаками в имени будет выдано соответственное сообщение об ошибке, так что запоминать этот набор не надо
2) файлы на диске хранятся в древовидной системе каталогов, начиная от корневого каталога обозначенного буквой диска
3) редактировать, создавать, удалять, копировать, вырезать, вставить, переименовать, поменять атрибуты, права, владельцев и тп
4) вопрос не ясен.
5) действие по умолчанию, то что происходит если дважды кликнуть на объект
0,0(0 оценок)
Ответ:
Juliaaaanaaa
18.02.2021 11:53
//где-то не закрыла begin end
var A:array [1..40] of integer;
sa,s3,s10,k,i: integer;
begin
sa:=0;
s10:=0;
s3:=0;
k:=0;
writeln('исходные значения');
for i:=1 to 40 do
begin
 A[i]:= random(21);
write(A[i],'')
end;
writeln;
for i:=1 to 40 do
 begin
 if A[i]mod 2<>0 then
begin
 sa:=sa+A[i];
k:=k+1;
if A[i]<10 then s10:=s10+A[i];
if A[i] mod 3=0 then
s3:=s3+A[i];                                     //здесь было странное выражение   
end;
end;                                                  //здесь
writeln('среднее арефмитическое нечетных чисел',sa/k:5:0);
writeln('сумма чисел, не превышающих', s10);
writeln('сумма чисел, кратных трем', s3);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота