saskii
08.10.2020 04:02

Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.
Питон

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kegemov
15.10.2020 05:36

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота