Dia1111111111111
02.02.2020 20:37

Индивидуальная работа
Учитель дает задание написать программу для вывода изображения:
Установить размер экрана 800, 600
Задний фон закрасить определенным цветом (цвет можно выбрать любой), поэкспериментируйте с цветами
Добавить на рабочую поверхность экрана космический корабль, файл shuttle.png
Установить на задний фон изображение Сатурна, файл saturn.jpg
Сохранить написанную программу

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Molly11111
18.04.2022 05:26
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const
  m = 10;

var
  t: array[1..m] of integer;
  i, n, nm, sm: integer;

begin
  //Заполняем массив сл.числами и подсчитываем
  //количество элементов и среднее арифметическое
  //согласно условию задачи
  for i := 1 to m do
  begin
    t[i] := random(-20, 20);write(t[i]:4);
    if (i > 1) and (i <= m) then
      if t[i] > t[i - 1] then n := n + 1
      else if t[i] < t[i - 1] then begin
        sm := sm + t[i];nm := nm + 1;
      end;
  end;
  writeln;
  writeln('число элементов больших предыдущего = ', n);
  writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);  
 
end.

Тестовое решение:
    6  13  19   8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5
0,0(0 оценок)
Ответ:
ksaro3
21.08.2021 05:18
Var x1,y1,x2,y2,v1,v2:real;
begin
  writeln("введите количество метров пробегания жирафа");
  read(y1);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x1);
  writeln("введите количество метров пробегания зайца");
  read(y2);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x2);
  v1:=y1/x1;
  v2:=y2/x2;
  if v1>v2 then 
  begin
     writeln("жираф чемпион");
  end
  else if v1<v2 then 
  begin
     writeln("заяц чемпион");
  end
  else
  begin
    writeln("победила дружба);
  end;
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота