Войти
Регистрация
Спроси ai-bota
Gesha11
14.11.2020 00:20
Разработать блок- схему алгоритма и программу решения : какое из двух растояний (s1 или s2) больше при условии, что первое из них находится в метрах, а второе в -саженях для справки: 1 сажень =2,134м
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
iva0607
23.03.2022 17:44
Выбери материальные модели....
tinaZ07
09.02.2021 20:35
Сколько существует средств навигации в Sketch Up (Дайте ответ в виде числа)...
shark741
03.01.2020 12:50
Определите к какому виду относится модель...
mashka710
27.11.2022 04:00
1) Укажите все общие понятия: Змей Горыныч Самое глубокое озеро Учебник Число Столица России 2) Мысленное установление сходства или различия объектов по существенным или...
dalakoff
06.08.2020 04:13
Укажите расширение файла БД..odb.docx.pdf...
MrAziimov1
01.06.2022 14:06
Задание 2 ( ). Заполните таблицу пятью примерами искусственных информационных процессов, протекающих в системах. Биологические системы Технические системы Человек Животный...
wwe555
20.08.2020 13:52
Перечислите достоинства и недостатки хранения информации в оперативной и долговременной памяти...
masyanyapar
20.08.2020 13:52
Как известно алгоритм можно записывать.какая из нижеперечисленных форм записей неприемлима для записи алгоритма? a)в словесной форме в)в табличной форме с)с блок-схем...
oe5d
16.11.2021 22:25
Укажите строчку в которой все существительные одного склонения солнце деревня сосед. стол кухня процессор. дядя бумага радуга. ночь книга ручка .двери клад стул...
sofiyabutina667
16.11.2021 22:25
Диаметр шара равен 29,4 см. значение числа π≈3,14. определи площадь поверхности шара, называемого сферой, (с точностью до десятых)....
Ответ:
крот21
07.08.2021 10:12
#include <stdlib.h>
#include <iostream>
#include <iomanip>
using namespace std;
int main() {
const int n = 5;
double a[n][n];
double m1, m2;
srand(time(0));
for (int i = 0; i < n; i++){
for (int j = 0; j < n; j++){
a[i][j]=-20 + (101.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << setprecision (2) << a[i][j];
}
cout <<endl;
}
m1=a[0][0];
m2=a[0][n-1];
for (int i = 1; i < n; i++){
if (a[i][i]>m1) m1=a[i][i];
if (a[i][n-i-1]>m2) m2=a[i][n-i-1];
}
cout << "m1=" << m1 << " m2=" << m2 << endl;
}
37.11 71.19 25.77 53.53 35.74
39.90 63.69 11.67 70.38 -4.10
64.46 52.37 35.03 42.58 69.18
44.22 8.46 13.23 71.17 3.10
6.83 65.07 75.24 21.61 37.22
m1=71.17 m2=70.38
0,0
(0 оценок)
Ответ:
chernenkopolina
12.09.2022 03:08
//Dev-C++ 4.9.9.2
//а
#include <iostream>
using namespace std;
const int n=10;
int main(){
int ar[n];
int arsub[n];
int m=0;
cout<<"Enter m:";
cin>>m;
cout<<"Enter array:"<<endl;
for(int i=0;i<n;i++)
cin>>ar[i];
for(int i=0;i<m;i++)
arsub[i]=ar[i];
for(int i=0;i<n-m;i++)
ar[i]=ar[i+m];
for(int i=0;i<m;i++)
ar[i+(n-m)]=arsub[i];
cout<<"Final array"<<endl;
for(int i=0;i<n;i++)
cout<<ar[i]<<' ';
cin.get();
cin.get();
return 0;
}
//б
#include <iostream>
using namespace std;
const int n=10;
int main(){
int ar[n];
int arsub[n];
int k,k1=0;
cout<<"Enter k:";
cin>>k;
cout<<"Enter array:"<<endl;
for(int i=0;i<n;i++)
cin>>ar[i];
for(int i=n-k;i<n;i++){
arsub[k1]=ar[i];k1++;}
for(int i=n;i>=k;i--)
ar[i]=ar[i-k];
for(int i=0;i<k;i++)
ar[i]=arsub[i];
cout<<"Final array"<<endl;
for(int i=0;i<n;i++)
cout<<ar[i]<<' ';
cin.get();
cin.get();
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота