albinashav
29.09.2021 18:08

язык питон
1) Сколько раз будет выполнено тело цикла?​

а) for i in range(15): s = s + 1​

б) for i in range(10, 15): s = s + 1​

в) for i in range(-1, 1): s = s + 1​

г) for i in range(1, 1): s = s + 1​

д) k = 5​

for i in range(k-1, k+1): s = s + 1
2)
Напишите программу, которая вычисляет сумму:

а) первых n натуральных чисел;

б) квадратов первых n натуральных чисел;

в) всех чётных чисел в диапазоне от 1 до n;

г) всех двузначных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ZLATA0061
25.01.2021 01:10
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var m:=ReadInteger('Количество элементов в массиве А (m):');
  var n:=ReadInteger('Количество элементов в массиве B (n):');
  var k:=ReadInteger('Позиция вставки k (1<k<m):');
  if (k>1) and (k<m) then begin
    var a:=ArrRandom(m,1,99); Writeln('Массив A'); a.Println;
    var b:=ArrRandom(n,1,99); Writeln('Массив B'); b.Println;
    Writeln('Результат вставки'); (a[:k]+b+a[k:]).Println
    end
  else Writeln('Вы нарушили условие 1<k<m')
end.

Тестовое решение
Количество элементов в массиве А (m): 10
Количество элементов в массиве B (n): 6
Позиция вставки k (1<k<m): 4
Массив A
68 64 30 75 36 15 50 39 92 26
Массив B
56 68 97 30 95 63
Результат вставки
68 64 30 75 56 68 97 30 95 63 36 15 50 39 92 26
0,0(0 оценок)
Ответ:
yana017
16.03.2022 17:37
Program smallest;<br /><br />var <br />a,b,c:integer;<br /><br />begin<br /><br />write('введите а: ');<br />readln(a);<br />write('введите b: ');<br />readln(b);<br />write('введите c: ');<br />readln(c);<br /><br />if (a - b) > 0 then <br />begin<br />if (a - c) > 0 then<br />writeln('a - наибольшее!');<br />end;<br /><br />if (b - a) > 0 then<br />begin<br />if (b - c) > 0 then<br />writeln('b - наибольшее!');<br />end;<br /><br />if (c - a) > 0 then<br />begin<br />if (c - b) > 0 then<br />writeln('c - наибольшее!');<br />end;<br /><br />end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота