clever113
03.10.2020 23:11

Задачи «Цикл с предусловием»
1 Напишите программу, в которой осуществляется ввод целых чисел (ввод
осуществляется до тех пор, пока не будет введён ноль) и подсчёт суммы
и среднего арифметического введённых положительных чисел.
2 Напишите программу, в которой осуществляется ввод целых чисел (ввод
осуществляется до тех пор, пока не будет введён ноль) и определение
максимального (наибольшего) из введённых чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Семма0106
15.10.2020 06:45

Объяснение:

Язык не был указан, так что пишу на С++:

1)

#include <iostream>

using namespace std;

int main()

{

   int buf, quantity = 0;

   cin >> buf;

   int sum = 0;

   while (buf != 0) {

       ++quantity;

       sum += buf;

       cin >> buf;

   }

   cout << "Sum: " << sum << "\nAverage: " << sum / quantity;

}

2)

#include <iostream>

using namespace std;

int main()

{

   int buf;

   cin >> buf;

   int max_num = buf;

   while (buf != 0) {

       if (max_num < buf) {

           max_num = buf;

       }

       cin >> buf;

   }

   cout << "Max: " << max_num;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота