lidochka4
15.01.2023 00:01

Язык программирования Паскаль

2 вариант

1. Использование writeln устанавливает курсор в…

1) … конец строки

2) … начало следующей строки

3) … конец выведенного текста

4) … начало текущей строки

2. Каждое предложение программы заканчивается…

1) … новой строкой

2) … точкой с запятой

3) … оператором stop

4) … запятой

3. Написать фрагмент программы, выводящий следующее:

1 2 3 4 5 6 7 8 9 10

1) for loop := 1 to 10 do write( loop, ' ' );

2) for loop := 1 to 10 do write( 'loop ' );

3) for loop := 1 to 9 do write( loop, ' ' );

4) for loop = 1 to 10 do write( loop, ' ' );

4. Какое ключевое слово не относится к циклической программе?

1) If

2) While

3) For

4) Until

5. Какой оператор цикла с предпроверкой условия?

1) Repeat

2) While

3) For

4) Until

6. Написать предложение, определяющее числовой массив из целых чисел в количестве 20.

1) type numbers = ARRAY[1..20] of int;

2) type numbers = ARRAY[1..20] of integer;

3) type numbers := ARRAY[1..20] of integer;

4) var numbers = ARRAY[0..19] of int;

7. Написать предложение, присваивающее число 20 четвертому элементу массива mynumbers.

1) mynumbers[3] = 20;

2) mynumbers[20] := 4;

3) mynumbers[4] = 20;

4) mynumbers[4] := 20;

8. Как обозначается массив?

1) Array

2) Dim

3) Procedure

4) Set

9. Процедуры и функции – это:

1) операторы

2) подпрограммы

3) имена

4) переменные

10. Оператор ввода в Паскале:

1) INPUT

2) PRINT

3) READ

4) WRITE

11. Когда используется выражение, которое начинается со слова IF, то обязательно применяется слово:

1) GOTO

2) THEN

3) THAN

4) ELSE

12. Функция арктангенса в Паскале обозначается:

1) ATG(X)

2) ATAN(X)

3) ARCTAN(X)

4) ATN(X)

13. Какое по типу выражение вычисляется в условии оператора if?

1) числовое выражение

2) неравенство

3) равенство

4) логическое выражение

14. Что вычисляет функция SQR в Паскале?

1) остаток от деления

2) квадратный корень

3) квадрат числа

4) модуль числа

15. Разветвляющийся алгоритм – это:

1) многократное исполнение одних и тех же действий

2) присутствие в алгоритме хотя бы одного условия

3) набор команд, которые выполняются друг за другом

4) вс алгоритм для дополнительных функций

16. В представленном фрагменте программы тело цикла выполнится …

d:=46

b:=11 WHILE d >= b DO d:= d - b

1) 4 раза

2) 3 раза

3) 2 раза

4) 1 раз

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Murmurmur29
10.12.2021 16:03
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
0,0(0 оценок)
Ответ:
tanyagorelik
28.02.2022 10:07
Какие такие графические оболочки?
неужто линукс?

KDE - или кеды, самые дружелюбные к пользователю
пример кедов на скрине (ток у меня специально упрощенный)

GNOME2 - отличная оболочка раньше была, но перешли на кеды, так как на смену пришел GNOME3

GNOME3 - многие плюются, многие восхищаются
кому как, мне лично понравилось, но пробыл с ним 2-3 месяца

XFCE - легкая оболочка, для нетбуков и т.п. - отличная вещь

LXDE - легкая оболочка, однако хоть и легче немного XFCE, но работать с ней - мазохизм

UNITY - столько радужных слов хочется сказать
уж слишком тормозит на древнегреческих компах
уж слишком много ресурсов ест
уж слишком много анимации
+ не удобное меню
используют его как правило ламеры/хомячки которые сидят на бубунту, и не знают, что есть другие оболочки

Отличаются как правило - заводскими программами при установке

Чем различаются типы графических оболочек
Чем различаются типы графических оболочек
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота