pukishandpapish
09.04.2020 16:41

3. Напишите программу, которая в последовательности целых чисел определяет максимальное число среди присутствующих в последовательности двузначных чисел. На вход программы подается количество чисел N, а затем сами числа.

Пример:

6

12

7

34

121

65

132 Результат: 65

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alibekovberkut
27.01.2022 18:15
Я так понимаю, что рассматривается ситуация, когда текстовая информация имеется, а ее надо как-то проанализировать.
Недостатки
 - сложно ставить пометки, мы привыкли делать пометки руками, и в электронном виде это все равно несколько неудобно.
 - самый большой недостаток, это то что нельзя выложить несколько листов и смотреть на них одновременно. Упираемся в размеры монитора и тд.
- усталость глаз от долговременной работы с монитором

Опять таки ко всему можно при если часто приходится делать, но для одноразового случая лучше распечатать информацию
0,0(0 оценок)
Ответ:
masdud2001
26.02.2022 12:08
#include <iostream>
#include <cmath>

class point
{
    int x;
    int y;
public:
    point(): x(0), y(0) {}
    void setkoord(int koordx,int koordy)
    {
        x = koordx;
        y = koordy;
    }
    int getx()const { return x; }
    int gety()const { return y; }
};

double length(point p1, point p2)
{
     return (sqrt(pow(double(p1.getx()-p2.getx()),2)+pow(double(p1.gety()-p2.gety()),2)));
}

int main()
{
    point A,B,C;
    B.setkoord(1,1);
    C.setkoord(1,0);
    double a=length(A,B), b=length(B,C), c=length(C,A);
    double p=(a+b+c)/2;
    double s=sqrt(p*(p-a)*(p-b)*(p-c));
    std::cout <<"square: " <<s <<std::endl;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота