Denis99133
11.09.2022 12:32

Нужно составить программу рисования имени даша! ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
NikaSempay
20.08.2022 10:39
Const n=20;
var a:array[1..n] of integer;
i,i1,i2,x:integer;
begin
Randomize;
a[1]:=random(10);
write(a[1],' ');
for i:=2 to n do
 begin
 a[i]:=a[i-1]+random(10);
 write(a[i],' ');
 end;
writeln;
write('x = '); readln(x);
i1:=1; i2:=n;
repeat
i:=(i1+i2) div 2;
if a[i]<x then i1:=(i1+i2) div 2+1;
if a[i]>x then i2:=(i1+i2) div 2-1;
until (a[i]=x)or(i1>i2);
if a[i]=x then 
 begin
 writeln('Искомый(ые) номер(а) элемента(ов):');
 while (i>0)and(a[i]=x) do i:=i-1;
 i:=i+1;
 while (i<=n)and(a[i]=x) do begin write(i,' '); i:=i+1; end;
 end
 else writeln('Элемент не найден');
writeln;
end.

Пример:
5 6 14 15 15 22 30 36 45 45 50 56 60 64 67 76 84 92 99 101 
x = 15
Искомый(ые) номер(а) элемента(ов):
4 5 
0,0(0 оценок)
Ответ:
Caflen
04.09.2021 06:06
1) Б и С
2) read(a) ввод в переменную с клавиатуры. a:=значение просто присваивание 
3) 

program a1; 
var a, b, c: integer; 
begin 
writeln('введите значения переменных a и b'); 
read(a, b); 
writeln((a+b+c)/3); 
end. 

Название программы и переменной были одинаковые. Так нельзя. Переименовал программу

4) б)

program znanija; 
var a, b, h: integer; 
begin 
writeln('Введите a, b и h'); 
read(a, b, h); 
writeln('Площадь трапеции ',(a+b)/2*h); 
end. 

5)

program znanija; 
var a, b, i: integer; 
begin 

read(a);

for i:=1 to a do 
begin   
b:=b + a mod 10;   
a:=a div 10; 
end;  

writeln(b);
end. 

Работает не только для трёхзначных. Но и двух, трёх, четырёх и т.д.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота