SofiZ2005
24.12.2021 06:02

Составить программу проверки знаний таблицы умножения с оценкой Составить программу проверки знаний таблицы умножения с оценкой Составить программу проверки знаний таблицы умножения с оценкой

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
2007пуля
06.03.2021 16:33
Var used: Set of Char;
    s1, s2: string;
    i: integer;
    done: boolean;
    c: char;

function IsLetter(c: char): boolean;
begin
  IsLetter := ((c >= 'a') and (c <= 'z')) or ((c >= 'A') and (c <= 'Z'));
end;

function UpperCase(c: char): char;
begin
  if (c >= 'a') and (c <= 'z') then
    UpperCase := Chr(Ord(c) - Ord('a') + Ord('A'))
  else
    UpperCase := c;
end;

begin
used := [];

readln(s1);
readln(s2);

for i := 1 to length(s1) do
  if (IsLetter(s1[i])) then
    include(used, UpperCase(s1[i]));

for i := 1 to length(s2) do
  if (IsLetter(s2[i])) then
    include(used, UpperCase(s2[i]));

done := False;
for c := 'A' to 'Z' do
  if not (c in used) then
  begin
    done := True;
    write(c);
  end;

if not done then
  write(0);

writeln;
end.
0,0(0 оценок)
Ответ:
liyakuper2
05.06.2023 11:20
//написано на си/си++
#include <iostream>#include <stdio.h>#include <time.h>
#define length 20
int main() { setlocale(LC_ALL, ""); srand(time(NULL));
int arr[length];
for (int i = 0; i < length; ++i) { arr[i] = rand() % 100 + 1; std::cout << arr[i] << "\n"; }
for (int i = 0; i < length; ++i) { if (arr[i] % 2 == 0) { for (int j = 0; j < length - 1; ++j) { if (arr[j] % 2 == 0) { if (arr[i] < arr[j]) {//сортировка будет происходить от Б к М int tmp = arr[i]; arr[i] = arr[j]; arr[j] = tmp; } } } } }
std::cout << "\nsorted array\n\n"; for (int i = 0; i < length; ++i) { std::cout << arr[i] << "\n"; }
system("pause"); return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота