Составить программу, определяющую принадлежность точки затенённой области, изображенной на рисунке задания.


Составить программу, определяющую принадлежность точки затенённой области, изображенной на рисунке

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
goshan14
13.03.2020 11:36
#include <stdio.h>
#include <math.h>

int main()
{
float x, y1, y2, y3; 
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f  %f  %f", y1,y2,y3);
else printf("%f  %f  %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f  %f  %f", y2,y1,y3);
else printf("%f  %f  %f", y2,y3,y1);
}
else if (y1<y2) printf("%f  %f  %f", y3,y1,y2);
else printf("%f  %f  %f", y3,y2,y1);
return 0;
}

Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
0,0(0 оценок)
Ответ:
Кауру
13.03.2020 11:36
#include <stdio.h>
#include <math.h>

int main()
{
float x, y1, y2, y3; 
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f  %f  %f", y1,y2,y3);
else printf("%f  %f  %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f  %f  %f", y2,y1,y3);
else printf("%f  %f  %f", y2,y3,y1);
}
else if (y1<y2) printf("%f  %f  %f", y3,y1,y2);
else printf("%f  %f  %f", y3,y2,y1);
return 0;
}

Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота