Карина111111111444
02.03.2022 18:26

На языке паскаль написать программу с цикла for 8кл ввести число,
2) считывать число, введённое с клавиатуры и его запоминать,
3) увеличивать заданное число в 3 раза для i от 1 до 10,
4) выводить на экран результат выполнения цикла

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
milana372
30.03.2022 23:59
Вообщем так.
1. sin это арифметическое действие. Синус можно найти из 90 градусов например. А тут X>10. Из чего синус искать, из большего или может из меньшего? Правильной будет запись 
if x>10 then ... какое-то действие... sin(x) else ... sin (x);
вообщем нельзя ставить оператор сравнения в арифметическое действие т.к. им задаются условия.

2. Попытка использовать арифметические операции с "false".
3. Выражение теряет смысл. And это логическая операция. Лог выражение должно быть вида A and B. Соответственно исправить можно так '(x=0) and (round(sqrt(x)) mod 2=0)' 
4. Не пишут 2 or подряд т. к. теряется логика операции.
0,0(0 оценок)
Ответ:
kkarinanexK
03.08.2020 11:04
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main(){
srand(time(0));
int n,m;
cin>>n;
cin>>m;
int **a=new int *[m];
for(int i=0;i<m;i++)
  a[i]=new int[n];
    cout<<"Matrix A:";
      for(int i=0;i<m;i++){
        cout<<"\n";
           for(int j=0;j<n;j++){
                 a[i][j]=rand()%17-7;
                     cout<<a[i][j]<<" ";
}
}
int *b = new int[m];
cout<<"\n Array B:";
for(int j=0;j<n;j++){
b[j]=0;
 for(int i=0;i<m;i++){
   b[j]=b[j]+a[i][j];
     }cout<<b[j]<<" ";
   }
cin.get();
cin.get();
return 0;
}
Блок-схема и программка на с++ получить матрицу а размера , заполненную случайными числами от -7 до
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота