ggggbbb90
03.05.2022 15:48

Информатика, 10 класс
решите задачу стандартными методами Паскаля, без сложных функций. (без чар и орд)

напишите программу которая выполняет шифрование строки с шифра цезаря​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shirowa234567815690
26.06.2020 21:29
а)свойства, действия, поведение, состояние
б) Отвечают на вопрос: "Чем может отличаться один объект от другого?" "Что может изменится у объекта при выполнении действия?!
в) Отвечают на вопрос: "Что он может делать?" (активное действие) или "Что с ним можно делать?" (пассивное действие)
г) имена действий, пошаговое составление описания каждого действия свойственного объекту.
д) человек называет или подразумевает определённое сочетание значений всех или некоторых свойств этого объекта                                                                            Может так?
0,0(0 оценок)
Ответ:
xmaxim99
13.03.2020 14:04

#include <iostream>

#include <algorithm>

#include <string>

#include <vector>

using namespace std;

int main()

{

    // Номер 1

   vector <string> days;

   for (int i = 0 ; i < 7 ; ++i)

   {

       string temp;

       cin >> temp;

       days.push_back(temp);

   }

   

   

   //Номер 2

   int max1 = -2000000000;

   int max2 = -2000000000;

   vector <int> arr { 15, 48, 0, 144 , 52};

   for(int i = 0 ; i < arr.size() ; ++i)

       max1 = (arr[i] > max1 ? arr[i] : max1);

       

   for(int i = 0 ; i < arr.size() ; ++i)

       max2 = (arr[i] > max2 && arr[i] != max1 ? arr[i] : max2);

   cout << "Максимум 1: " << max1 << " Максимум 2: " << max2;

   

   

   //Номер 3

   vector <int> numbers { 15, 24, 48, -5 , 0 , -10};

   cout << count_if(numbers.begin(), numbers.end(), [] (int a) { return a > 0;});

   

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота