ivanapushkin10
27.04.2020 01:30

C#
Написать программу, в которой вводятся с клавиатуры предложения, и выводит на экран только цитаты, то есть предложения, заключенные в кавычки.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vika0289111
15.10.2020 12:45

using System;

using System.Text.RegularExpressions;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           string s;

           Console.WriteLine("Введите текст:");

           s = Console.ReadLine().Replace('\"','\'');

           Regex r = new Regex(@"'[^']+'");

           foreach (Match m in r.Matches(s))

               Console.WriteLine(m.Value);

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота