katevina
27.11.2021 15:06

2. Составить программу для нахождения 25-го элемента арифметической прогрессии. Первый элемент равен 5. Приращение прогрессии (шаг) равен 6.
3. В одномерном массиве b[n], заданном с датчика случайных чисел, найти максимальный элемент Составить программу для нахождения 25-го элемента арифметической прогрессии. Первый элемент раве">

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Mary2304Cat
15.10.2020 12:58

//FIRST

#include <iostream>

using namespace std;

int main()

{

   int n1;//Первый элемент

   cin>>n1;

   int step;//Шаг прогрессии

   cin>>step;

   int quantity;//Какой элемент найти

   cin>>quantity;

   cout<<n1+ (quantity-1)*step;

   return 0;

}

//

//SECOND

//Использовал STL

#include <iostream>

#include <ctime>

#include <cstdlib>

#include <algorithm>

#include <vector>

using namespace std;

int main()

{

   srand(time(NULL));

   int n;

   cin>>n;

   vector<int>arr(n);

   for(int i = 0;i<n;i++){

       arr[i]=rand()%100;

   }

   sort(arr.begin(), arr.end());

   cout<<arr[n-1];

   return 0;

}

//4 - X3

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота