Maxi2007
14.12.2022 04:28

Составьте программу, которая реализует
ввод с клавиатуры трех произвольных
положительных чисел а, b и c. Возводит в
квадрат только нечетные числа, а четные
оставляет без изменения. Новые значения
выводит на экран.
2.Некоторый автомат может за два
числа и выполнить 3 команды. Составьте
программу, которая по команде 1
преобразует имеющуюся пару чисел (х, у) в
пару (х-у, у), по команде 2 преобразует пару
чисел (х, у) в пару (х+у, у), по команде 3
преобразует пару (x, у) в (у, х).
3.Составьте программу, которая по коду
операции N выполняет над целыми числами
а и b (b0) указанное действие и выводит
результат. Арифметические действия
(операции) над числами обозначены: 1 –
сложение, 2 – вычитание, 3 – умножение, 4
– деление.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lootfarm
18.11.2020 07:42

1) #include <iostream>

#include <vector>

using namespace std;

int main() {

vector<int> arr;

int N;

int sum = 0;

cin >> N;

for(int i = 0; i<N; ++i) {

int temp;

cin >> temp;

arr.push_back(temp);

if(i==0) {

sum = arr[i];

} else {

sum*=arr[i];

}

cout << "Sum: " << sum;

}

2) #include <iostream>

#include <vector>

using namespace std;

int main() {

vector<int> arr;

int N;

cin >> N;

int sum2(0), sum3(0);

for(int i = 0; i<N; ++i) {

 int temp;

 cin >> temp;

 arr.push_back(temp);

 if(arr[i]>9&&arr[i]<100) {

  if(sum2==0) {

   sum2=arr[i];

  } else {

   sum2*=arr[i];

  }  

 } else {

  if(arr[i]>99&&arr[i]<1000) {

   sum3+=arr[i];

  }

 }

}

cout << "Sum2: " << sum2 << endl << "Sum3: " << sum3;

}

0,0(0 оценок)
Ответ:
frausadykova20
24.03.2020 07:28

Using System;

namespace chislaabc

{

   class Program

   {

       static void Main(string[] args)

       {

           int a, b, c;

           

           Console.WriteLine(“Введите число a”);

           a = Convert.ToInt32(Console.ReadLine());

               Console.WriteLine(“Введите число b”);

           b = Convert.ToInt32(Console.ReadLine());

               Console.WriteLine(“Введите число c”);

           c = Convert.ToInt32(Console.ReadLine());

           if (a == b || a == c || b == c)

           {  

              Console.WriteLine(«Есть хотя бы одна противоположная пара»);  

           }

           else

           {

               Console.WriteLine(«Противоположных чисел нет»);

           }

           Console.ReadKey();

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота