Uliana1pa
15.09.2020 16:52

На Питоне и С++ Обратное число
На каждый за нужно вывести в отдельной строке целое число 0
Входные данные
В первой строке дано целое число t — количество за
В следующих t строках даны по два числа pi и ai, i=1,…,t.

Выходные данные
Выведите t целых чисел (каждое число в отдельной строке) — ответы на за

Примеры
Ввод
4
5 1
5 2
5 3
5 4
Вывод
1
3
2
4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zhadyra1984
11.02.2022 15:34

Задание №1:
int(-5,89)= -5
int(0,53)=0
round(-5,8)=-6
round(5,2)=5
frac(-17,4)=0,4
frac(0,32)=0,32
trunc(-17,4)=-17
trunc(15,2)=15
45 div 4=11
15 mod 8=7
(489 div 10) mod 10=8

Задача №2:

а=1, в=2;     a=2

а=3, в=3;    a=0

а=4, в=2;    a=2

а=-3, в=5    a=-15

Задача №3:

var m,s:integer;
begin
readln(m);
readln(s);
if s>m then writeln('Саша старше Маши')
        else if m>s then writeln('Маша старше Саши ')
              else writeln('Саша и Маша ровесники');
end.

Задача №4:

var a:real;
begin
write('Введите число: ');
readln(a);
if a>0 then a:=a/7
        else a:=a*a;
writeln(a);
end.

Задача №5:

var a,b:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
if a>b then writeln('Наибольшее число: ',a)
        else writeln('Наибольшее число: ',b);
end.

Задача №6:

var a,b,c,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
writeln('Наибольшее число: ',p);
end.

Задача №7:

var a,b,c,d,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
write('Введите четвертое число: ');
readln(d);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
if p<d then p:=d;
writeln('Наибольшее число: ',p);
end.

Задача №8:

var a:real;
begin
a:=0;
while a<7.9 do
begin
  write('Введите скорость ракеты: ');
  readln(a);
  if (a>=7.9) and (a<11.2) then writeln('Ракета станет спутником Земли')
    else if (a>=11.2) and (a<16.6) then writeln('Ракета станет спутником Cолнца')
          else if a>=16.6 then writeln('Ракета покинет Cолнечную систему')
                          else writeln('Требуется повторный ввод скорости');
end;
end.

0,0(0 оценок)
Ответ:
Регина2411
02.04.2022 03:03

N= 2^{i}

"N" - мощность алфавита.

информационный вес символа алфавита "i"

#1. N=2 в степени i

Так как N=32, отсюда следует, что i=5 битам.

#2. По аналогии выше. Только теперь N=8. А 8 - это 2 в степени 3.

то есть i=3. 3 бита.

#3. 64 символа. (смотреть задачу 1). 2 в 6 степени.

#4. Определим, сколько бит занимает все сообщение.

1/512 Мбайт = 1024/512 = 2 Кбайт. (1 Мбайт = 1024 Кбайт);

2 Кбайт = 2 * 1024 = 2048 байт (1 Кбайт = 1024 байт);

2048 байт = 2048 * 8 = 16384 бит.

Текст состоит из 2048 символов ⇒ занимает 16384 бит ⇒ один символ занимает 16384 : 2048 = 8 бит = 1 байт.

Если для хранения 1 символа алфавита используют 8 бит, согласно формуле (смотреть выше) 2 ^ 8 = 256 символов.

ответ: размер алфавита - 256 символов.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота