Анна200361
11.10.2021 11:26

Составить программу на языке паскаль для вычисления суммы всех четных чисел на интервале от 1 до н. (9 )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Povelitel2004
09.06.2020 21:57

Объяснение:

var

i,n,s:integer;

begin

write('Введите n=');

readln(n);

s:=0;

while i<=n do

begin

if i mod 2=0 then s:=s+i;

i:=i+1;

end;

writeln('s=',s);

readln;

end.

И чуть короче с циклом for

var

i,n,s:integer;

begin

write('Введите n=');

readln(n);

s:=0;

for i:=1 to n do

if i mod 2=0 then s:=s+i;

writeln('s=',s);

readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота