KiskaSofia
13.09.2021 12:29

Во Free Pascal составьте программу вычисления арифметического выражения y=x^2 - 7x, если x<0, либо y= 10 + 5x, если

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
228ie228
04.09.2021 02:35
#include <iostream>
#include <vector>
using namespace std;

int main() {
cout << "Введите массив (0, чтобы закончить):\n";
int k,
sb = 0, cb = 0,
sg = 0, cg = 0;
vector<int> v;
while (true) {
cin >> k;
if (k == 0)
break;
else
v.insert(v.end(), k);
}
for (int i = 0; i < v.size(); i++) {
if (v[i] < 0) {
sb += -1 * v[i];
cb++;
}
else {
sg += v[i];
cg++;
}
}
cout << "Средний рост юношей: "
<< (sb / cb) << '\n'
<< "Средний рост девушек: "
<< (sg / cg) << '\n';
return 0;
}
0,0(0 оценок)
Ответ:
НикВероник1
02.04.2020 08:00

ку:



ст — це витвір мовленнєвого процесу, що відзначається завершеністю, об'єктивований у вигляді письмового документа, літературно опрацьований відповідно до типу документа, витвір, який складається із заголовка і ряду особливих одиниць (надфразових єдностей), об'єднаних різними типами лексичного, граматичного, логічного, стилістичного зв'язку, і має певну цілеспрямованість і прагматичну визначеність»[1] (І. Р. Гальперін)(рос.).

«Текст — певна, з функціонально-смислового погляду упорядкована, група речень або їх аналогів, які являють собою, завдяки семантичним і функціональним взаємовідношенням елементів, завершену смислову єдність»[Джерело?] (В. В. Одинцов).

Найістотнішими текстовими ознаками є (А. П. Загнітко):

цілісність;зв'язність;структурна організованість;завершеність.

Текст — середній елемент схеми комунікації, яку можна уявити у вигляді триелементної структури: автор (адресант) → текст → читач (адресат). Як серединний (проміжний) елемент комунікативного акту текст виявляє свою специфіку у кодуванні і декодуванні. Щодо мовця (адресанта) текст є кодованою величиною, оскільки мовець кодує певну інформацію. Для сприйняття вміщеної у тексті інформації читач повинен її декодувати (А. П. Загнітко).

Текст породжується мовцем, тим, хто пише, відповідно до його задуму, з потребою найкращого передавання змісту. Текст редагується на етапі внутрішньої, мислиннєвої підготовки, а в письмовому варіанті — також в процесі саморедагування, відповідно до стилістичних норм мови, комунікативної доцільності в кожній окремій ситуації.

У сучасному мовознавстві виділилися два підходи у лінгвістичних дослідженнях текстів:

функціональна типологія (соціальні функції й мета використання текстів) іструктурна типологія (внутрішня організація текстів) (М. Р. Львов)[Джерело?].

Перший напрям значно відтворює традиційну для риторики класифікацію, що зближує типи мовлення (тексту) з жанрами: це розповідь, опис, роздум. Інший, структурний, підхід («лінгвістика тексту») пов'язаний з виявленням, вивченням і моделюванням внутрішньотекстових зв'язків, причому вводиться поняття «компонента тексту» (абзацу, надфразної єдності, складного синтаксичного цілого тощо).

Основні категорії тексту[ред. • ред. код]

Текст, особливо художній, на думку А. П. Загнітка, складний і багатоплановий, оскільки завданням його інтерпретації є вияв максимуму закладених у ньому думок і почуттів художника (автора). І тому тут доречно буде подати основні текстові категорії та розтлумачити їх.

Цілісність тексту пізнається через його взаємозв'язані категорії — категорію членованості і категорію зв'язності. Кожен компонент тексту характеризується відносною смисловою завершеністю.

Формальну зв'язність тексту називають когезією (В.Дреслер), зовнішньою злитістю (К.Кожевнікова); змістову зв'язність — когерентністю (В.Дреслер), внутрішньою злитістю (К.Кожевнікова), інтегративністю (І. Р. Гальперін) .

Нерозривна єдність доцентрових і відцентрових сил у тексті виявляється у проспекції і ретроспекції (А. П. Загнітко). Ретроспекція насичена такими компонентами, як тематичні слова (пам'ять, спогад), граматичний час — теперішній історичний, прислівники місця і часу («тоді», «там», «колись» тощо).

Художній текст не існує без сформульованої ідеї твору (концепта), який є визначальною його категорією. Ще одна категорія — модальність тексту — є обов'язковою у художньому творі. Поза нею текст як комунікативний елемент — не існує. «Модальність тексту починається ще до його створення: з першого акту авторського вибору — теми і проблеми твору» (А. П. Загнітко).

Якщо розглядати текст як структуровану одиницю, необхідно зазначити про наявність текстових парадигм:

жанрова (жанр визначає структурні особливості твору);функціонально-стильова (об'єднує тексти за функціональним спрямуванням);індивідуально-авторська (об'єднує всі твори одного автора).

Інформативність тексту — здатність тексту бути носієм завершеного повідомлення, передавати інформацію. Інформативність як важлива властивість тексту характеризує кількість інформації, що міститься в ньому, її важливість і новизну.

Засоби зв'язку в тексті[ред. • ред. код]

Засобами зв'язку в тексті можуть бути такі елементи, що забезпечують єдність стилю:

Змістові, логічні і психологічні зв'язки:єдність місця, часу, дійових осіб;зв'язок з минулим і майбутнім (єдність сюжету).Літературні, риторичні засоби зв'язку:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота