valoparina
23.03.2020 01:10

Код на питона и на с Разложение на чётнопростые
В этой задаче рассматриваются только чётные целые числа.

Чётное натуральное число n будем называть чётнопростым числом, если его нельзя представить в виде произведения двух чётных чисел. Например, числа 2 и 6 — чётнопростые.

Очевидно, что каждое число либо является чётнопростым, либо разлагается в произведение чётнопростых. Но такое разложение на чётнопростые не всегда единственно.

Входные данные

Дано чётное натуральное n≤109.

Выходные данные

Если число n чётнопростое, выведите слово prime. Если это число единственным образом разлагается в произведение двух и более чётнопростых, то выведите слово single, а в следующей строке выведите разложение этого числа на чётнопростые множители. Если число допускает несколько различных разложений на чётнопростые, то выведите слово many, а в следующих двух строках выведите два каких-нибудь различных разложения числа на чётнопростые множители.

Примеры
Ввод 1
6
Вывод
prime
Ввод 2
4
Вывод
single
2 2

очень на вас надеюсь

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lizaaf
13.11.2020 03:08

3. CREATE TABLE

нужны имя полей и тип их данных, например уникальный ID это id = PRIMARY KEY

текст = text , не пустой текст = TEXT NOT NULL ,

числа = REAL,INT время = DATE и т.д

6. SELECT, FROM, GROUP BY, WHERE, ORDER BY, HAVING

7. SELECT - указывает , что извлекать из таблицы, так же может содержать агрегирующие функции и функции времени такие как EXTRACT, DATE_TRUNC

8. FROM - указывает из какой таблицы извлекать, так же можно указать подзапрос

9. WHERE - указывает какие условия нужны для извлечения , которые указаны в SELECT, не может сравнивать агрегирующие функции , для этого есть HAVING, также может содержать подзапрос

10. GROUP BY - групирует по .., HAVING - то же самое , что WHERE , только для агрегирующих функций

11. ORDER BY - использует методы ASC(по возрастанию значений) пример - имя_поле ASC, или DESC(по убыванию значений) - имя_поля DESC

Объяснение:

Будут вопросы напиши в коменты(

0,0(0 оценок)
Ответ:
bashkirovarima
04.10.2020 00:15
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var n:=ReadInteger('n=');
  var a:=MatrixRandom(n,n,10,99);
  var s:=0;
  var k:=0;
  for var i:=0 to n-1 do begin
    for var j:=0 to n-1 do Print(a[i,j]);
    Writeln;
    if a[i,i].IsEven then begin s+=a[i,i]; Inc(k) end;
    end;
  if k>0 then Writeln('S=',s/k:0:2)
  else Writeln('На главной диагонали нет четных элементов')
end.

Тестовое решение
n= 8
63 13 33 90 25 21 87 91
88 88 48 13 30 59 81 27
73 23 76 77 52 19 33 97
53 87 13 74 17 35 61 70
77 96 51 61 82 33 63 22
39 88 84 54 88 73 74 69
76 26 69 14 45 80 70 54
80 36 47 38 18 22 84 62
S=75.33
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота