Danilos01
03.12.2021 18:55

Язык Python3 Простое число
По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число.

Входные данные

Во входном файле находится одно натуральное число K.

Выходные данные

В выходной файл выведите K-е простое число.

Примеры

Ввод:
3
Вывод:
5
Ввод:
1
Вывод:
2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katyu1234
15.10.2020 14:00

Ну, можно так:

Объяснение:

def prostoe(chislo):

   a = True

   for i in range(2, chislo//2 + 1):

       if chislo % i == 0:

           a = False

           break

   return a

k = int(input("Введите число, не превосходящие 100000: "))

schetchic = 1

a = 2

while k >= schetchic:

   if prostoe(a):

       prostoi = a

       schetchic += 1

   a += 1

print(prostoi)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота