Fkbyfitdxtyrj
12.10.2020 20:39

Составить программу вычисления значения функции на языке С ++. ">

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Valeria12351778
28.12.2021 03:50
//PascalABC.NET 3.1 сборка 1239
const
    n = 10;
    m = 10;

var
    i, j: integer;
    a, b: array[1..n, 1..m] of integer;
    f: boolean;

begin
    for i := 1 to n do
    begin
        for j := 1 to m do
        begin
            a[i, j] := random(50);
            write(a[i, j]:3, ' ');
        end;
        writeln;
    end;
    writeln;
    
    for i := 1 to n do
    begin
        f := false;
        for j := 1 to m do
        begin
            if not f and (a[i, j] mod 2 = 1) then begin
                a[i, j] := 2 * a[i, j];
                f := true;
            end;
            write(a[i, j]:3, ' ');
        end;
        writeln;
    end;
end.
0,0(0 оценок)
Ответ:
sasha322322
22.06.2021 14:26

1)var

a:array[1..5]of integer;

i,n,s:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 s:=0;

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then s:=s+a[i]

 end;

 writeln('Сумма положительных элементов массива равна ', s)

end.

2)var

a:array[1..10]of integer;

i,n,P:integer;

begin

 writeln('Введите число элементов');

 readln(n);

 writeln('Введите число');

 P:=1;

 for i:=1 to n do begin

   read(a[i]);

   if a[i] mod 6 = 0  

   then P:=P*a[i]

 end;

 writeln('Произведение элементов массива кратных 6 равна ',P)

end.

3)var

a:array[1..5]of integer;

n,i:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then begin

   a[i]:=a[i]*3;

   writeln('Новый элемент равен: ',a[i])

 end;

 if a[i]<=0 then begin

   a[i]:=a[i]+5;

    writeln('Новый элемент равен: ',a[i])

 end;

 end;

end.

Буду рад если отметишь мой ответ как лучший

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота