Anuffka
09.05.2023 00:46

или pascal) Заданы N целых чисел. Требуется найти, сколько из этих чисел строго меньше N. Формат ввода Первая строка входных данных содержит одно целое число N (1 ≤ N ≤ 105). Вторая строка содержит N целых чисел ai (-109 ≤ ai ≤ 109). Формат вывода Выведите одно число — количество ai, строго меньших N. Пример Ввод Вывод 5 -10 4 10 5 2 3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kristina052602
15.09.2020 01:39

N = int(input())

a = [0] * N

for i in range(0, 5):

   a[i] = int(input())

col = 0

for j in a:

   if j < N:

       col += 1

print(col)

0,0(0 оценок)
Ответ:
Данилкамастре
15.09.2020 01:39

--- Python 3.8.3 ---

import typing

from typing import Callable

from typing import AnyStr

from typing import Any

from typing import Iterable

from typing import List

def SeqCount(Seq: Iterable[Any], predicate: Callable[[Any], bool]) -> int:

   counter = 0

   for item in Seq:

       if predicate(item):

           counter+=1

   return counter

def main():

   n = int(input())

   Seq = list(map(int, input().split(maxsplit = n)))

   print(SeqCount(Seq, lambda  item: item < n))

if __name__ == "__main__":

   main()

Проходит предложенный вами тест + пару придуманных лично мной

формат ввода ([Enter] - пользователь нажимает кнопку ввода. ">>>" - вывод программы):

5 [Enter]

-10 4 10 5 2 [Enter]

>>> 3

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота