лимон2509
28.06.2020 16:24

Написать программу на С++, которая: -предлагает пользователю ввести предложение,
-считывает введенную строку,
-предлагает пользователю ввести символ,
-считывает введенный символ,
-добавляет символ пользователя после каждого пробела во введенной ранее строке
-выводит результат

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
мансур45
24.08.2020 23:47

#include <iostream>

int main() {

 std::string str;

 char n;

 std::cout << "Input your string: ";

 getline(std::cin, str);

 std::cin.clear();

 std::cout << "Input your character: ";

 std::cin >> n;

 for (int i = 0; i < str.size(); ++i) {

   if (str[i] == ' ')

     str.insert(i + 1, 1, n);

 }

 std::cout << str << "\n";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота