Решить на языке питон 3. Петя, Катя и Сережа делают из бумаги журавликов. Вместе они сделали S журавликов. Сколько журавликов сделал каждый ребенок, если известно, что Петя и Сережа сделали одинаковое количество журавликов, а Катя сделала в два раза больше журавликов, чем Петя и Сережа вместе? Формат ввода Записано одно натуральное число S – общее количество сделанных журавликов ( S < 10 в 6 степени ) . Формат вывода Вывести три числа, разделенных пробелами – количество журавликов, которые сделал каждый ребенок (Петя, Катя и Сережа).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Farman2001
13.10.2022 15:28

def sqc(xa,ya,xb,yb,xc,yc) :

   return ((xb - xa) * (yc - ya) - (xc - xa) * (yb - ya)) / 2

 

xa, ya, xb, yb = map(float,input().split())

n, m = map(int,input().split())

astra = []

sc  = []

res, smax = 0, 0

for i in range(n) :

   xc, yc = map(float,input().split())

   astra.append((xc,yc))

   sctmp = sqc(xa,ya,xb,yb,xc,yc)

   if smax < abs(sctmp) :

       smax = abs(sctmp)

   #print(sctmp)

   sc.append(sctmp)

for i in range(m) :

   xc, yc = map(float,input().split())

   sp = sqc(xa,ya,xb,yb,xc,yc)

   if smax < abs(sp) :

       smax = abs(sp)

   #print(sp)

   for j in range(n) :

       xd, yd = astra[j][0], astra[j][1]

       if sp * sc[j] < 0 :

           if smax < abs(sp * sc[j]) :

               smax = abs(sp * sc[j])

print('{:.2f}'.format(smax))

У меня получилось.

0,0(0 оценок)
Ответ:
angelina3404
13.10.2022 15:28

Объяснение:

1. • мышь • клавиатура • экран дисплея.

2. • графический дисплей

3. • пикселем.

4. растром.

5.  фрактальной & растровой

6. совокупность трех зерен люминофора.

7. Устройство, управляющее работой графического дисплея.

8. Электронное, энергозависимое устройство для хранения двоичного кода изображения, выводимого на экран.

9. 256 битов

10. Принтер.

11. 2 раза

12. Векторной.

13. сокращает объем памяти, необходимой для хранения изображения, и облегчает редактирование последнего

Объяснение:

1. (Если надо один ответ, то клавиатура)  

3. Почему? ответ: на всех остальных делает машина, а тут саморучно

11. Что бы доказать для представления 65536 цветов требуется 16 чисел (00010000000000000000), а для 256 цветов - 8 (000100000000). 16 / 8 = 2.

Дальше не знаю

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота