bellalove200
09.07.2021 12:08

Решить на языке питон Алиса и Боб получили три большие кучки конфет в качестве подарка. Теперь они хотят разделить эти конфеты между собой настолько честно, насколько это возможно. Чтобы сделать это, Алиса забирает одну кучку с конфетами себе, затем Боб забирает одну из других двух кучек себе. Последняя кучка делится между Алисой и Бобом так, как они хотят: например, возможно, что Алиса возьмет всю кучку себе, а Боб не получит из нее ничего. После того как они возьмут все конфеты из кучек, если у Алисы будет больше конфет, чем у Боба, она выкидывает некоторые конфеты таким образом, что количество ее конфет становится равным количеству конфет Боба. Конечно, Боб сделает то же самое, если у него больше конфет. Алиса и Боб хотят иметь как можно больше конфет каждый, и будут планировать процесс разделения конфет соответственно посчитайте максимально возможное количество конфет, которое может оказаться у Алисы после процесса их разделения (конечно же, у Боба будет столько же конфет). Формат ввода Единственная строка запроса содержит три целых числа a , b и c ( 1 ≤ a , b , c ≤ 1 0 в 16 степени ) — количество конфет в первой, второй и третьей кучках соответственно. Формат вывода Выведите ответ - максимальное количество конфет, которое Алиса может иметь после разделения, если и Алиса, и Боб будут действовать оптимально (конечно же, Боб будет иметь такое же количество конфет).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Maksim2553
29.07.2022 20:38

      саксофон     пиан      ударн                    географ.фак     ист.фак   физ.фак.  биолог

М          +                 -              -                                     -                     -                                      

В           -                +              -                                      +                    -                -                  -

А           -                  -             -                                     -                    +                 -                 -            

Л           -                 -             +                                      -                   -                                         

 

Валерий пианист - географич. фак 

0,0(0 оценок)
Ответ:
КореневаАня
29.07.2022 20:38
Код

var
    x, y, z, a, b, c, d, t: integer ;

begin
    x := 336;
    y := 8;
    x := x div y;
    y := x mod y;
    writeln('x = ', x, ', y = ', y);
   
    a := 1686;
    b := (a div 10) mod 5;
    a := a - 200 * b;
    writeln('a = ', a, ', b = ', b);
   
    x := 11;
    y := 5;
    t := y;
    y := x mod y;
    x := t;
    y := y + 2 * t;
    writeln('x = ', x, ', y = ', y, ', t = ', t);
   
    x := 19;
    y := 3;
    z := y * 2;
    y := x mod y;
    x := x - z;
    y := y + z;
    writeln('x = ', x, ', y = ', y, ', z = ', z);
   
    x := 13;
    y := 3;
    z := x;
    x := z div y;
    y := x;
    writeln('x = ', x, ', y = ', y, ', z = ', z);
end.

Вывод и ответы по очереди

1) x = 42, y = 2
2) a = 1086, b = 3
3) x = 5, y = 11, t = 5
4) x = 13, y = 7, z = 6
5) x = 4, y = 4, z = 13
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота