valeryaka
11.06.2020 07:22

Напишите программу, которая вводит трехзначное число и находит сумму цифр этого числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
IrinaCipher
10.06.2020 12:35

var

a,b,c,n,s: integer;

begin

readln(n);

if ((n>99) and (n<1000)) then

begin

a:=n div 100;

b:=n div 10 mod 10;

c:=n mod 10;

s:=a+b+c;

writeln('Сумма трех цифр равна ',s);

end else writeln('Введите трехзначное число!');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота