Марриичка
21.08.2022 03:30

Запиши фрагмент алгоритма на языке паскаля и определите значения целочисленных переменных x и y после выполнения фрагмента:​


Запиши фрагмент алгоритма на языке паскаля и определите значения целочисленных переменных x и y посл

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Yana05050
30.08.2022 09:09

1.

program z1;

const n=5;

var a:array [1..n,1..n] of integer;

i,j,s:integer;

begin

writeln ('Квадратная матрица:');

for i:= 1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=Random(10);

write(a[i,j]:3);

if i=j then s:=s+a[i,j]

end;

writeln;

end;

writeln('Среднее арифметическое элементов расположенных на главной диагонали: ',s/n)

end.

2.

program z2;

const n=5;

var a:array [1..n,1..n] of integer;

i,j,s,sp:integer;

begin

writeln ('Квадратная матрица:');

for i:= 1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=Random(21)-10;

write(a[i,j]:5);

if i=j then s:=s+a[i,j]

end;

writeln;

end;

for i:= 1 to n do

for j:=1 to n do

if (a[i,j]>0) and (a[i,j]>s/n)then sp:=sp+a[i,j];

writeln('Сумма положительных элементов, превышаюших по величине среднее арифметическое всех элементов расположенных на главной диагонали: ',sp)

end.

3.

program z3;

const n=5;

var a:array [1..n,1..n] of integer;

i,j,m,k:integer;

begin

writeln ('Двумерный массив:');

for i:= 1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=Random(21)-10;

write(a[i,j]:5)

end;

writeln;

end;

m:=a[1,1];

for i:= 1 to n do

for j:=1 to n do

if a[i,j]<m then m:=a[i,j];

writeln ('Минимальный элемент ',m);

k:=0;

for i:= 1 to n do

for j:=1 to n do

if a[i,j]=m then

begin

writeln('Индексы [',i,',',j,']');

k:=k+1;

end;

writeln ('Количество минимальных элементов ',k)

end.

0,0(0 оценок)
Ответ:
Лиза2005111111111
09.05.2020 03:27

Объяснение:

1. Підготовчий етап

На цьому етапі необхідно сформувати основну ідею майбутнього сайту.

Потрібно визначити яка мета буде у сайту, наприклад, мета може бути така: навчання, розвага, інтернет-магазин, продаж будь-яких послуг, бізнес сайт, або просто заробіток на сайті.

Потім визначаємо цільову аудиторію (стать, вік, освіта), тобто для кого буде цей сайт.

Так само необхідно з'ясувати яку інформацію очікують відвідувачі, це до з визначенням контенту (текстовою інформацією) на сайті.

Навігація-важливий пункт. Все повинно бути інтуїтивно зрозуміло, де і що знаходиться, щоб користувач не бродив у пошуках потрібної інформації, а відразу орієнтувався на сайті.

2. Розробка макета

Після постановки завдань майбутнього сайту, настає наступний етап-розробка макета. Орієнтуючись по пунктах ТЗ розробляється майбутній шаблон, або шаблони, з яких можна вибрати потрібний варіант.

Потім надається в форматі PSD (з усіма шарами) і у вигляді картинці, тут можна використовувати будь-який формат ( JPEG, PNG), щоб в подальшому передати роботу в руки верстальника.

3. Верстка

Щоб нарізати готовий макет на частини, і в подальшому прикріпити на сайт, буде потрібно верстальник.Верстка це процес написання HTML і CSS кодів для веб-сторінок. Кожен код відповідає за те, щоб всі елементи на сторінці розміщувалися там, де потрібно.

Види верстки при створенні сайту:

Блочний. Переваги блокової верстки полягає в тому, що вона правильно відображає всі елементи сайту на різних пристроях (наприклад, на мобільних телефонах). Компактний код, всі елементи важать менше, а значить сторінка буде завантажуватися швидко. З недоліків можна відзначити, що при використанні різних браузерів верстка може по

Табличний. У табличній верстці можна створювати колонки, таблиці в браузерах виглядають майже однаково. Недоліки: індексація такого сайту дуже повільна, довго завантажуються сторінки і код такої верстки занадто великий.

4. Програмування

На цьому етапі йде розробка механізмів системи адміністрування сайту, яка в майбутньому дозволить співробітникам компанії змінювати/оновлювати інформацію на сайті. Тобто створюється робоча версія сайту .

Мова програмування являє собою знакову систему, яка призначена для опису алгоритмів.

Після всіх цих дій сайт публікується в мережі.

5. Наповнення сайту контентом

Ефективність роботи сайту пов'язана з поняттям контенту, тобто текстової та графічної інформації.

Зазвичай на сайтах використовують SEO-копірайтинг, ця техніка створення текстів для сайту, яка враховується не тільки особливістю сприйняття користувачем, але і необхідна для просування в пошуковій системі.

6. Розкрутка сайту

Повністю готовий і наповнений інформацією сайт не гарантуватиме приплив користувачів. Для того, щоб на ваш сайт заходили відвідувачі, про нього в першу чергу треба заявити.

Щоб підвищити відвідуваність сайту, його в першу чергу треба зареєструвати в пошукових системах, так само можна зробити обмін посиланнями, або банерами. Щоб не возиться з цим самому, зазвичай замовляють розкрутку у тих же фрілансерів.

7. Підтримка сайту

Тут слід врахувати яким чином будуть додаватися або редагуватися матеріали і розділи сайту. Для таких цілей виділяється співробітник, який буде стежити за частотою оновлення.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота