vehera087
24.04.2023 09:56

Составьте программу которая выводит результат соединения тепло и ход в теплоход

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
79366
19.10.2020 11:39

Free Pascal.  Все три задания в одном коде.

Объяснение:

const k=10;

var

 a, i, n: integer;

 s : double;

 ar : array[0..k-1] of integer;

begin

 writeln('Задание 4');

 write('Введите число : ');

 readln(a);

 for i:=8 to 18 do

   if a>=0 then

     write(sqrt(i):2:2, '  ')

   else

     writeln((i+0.8):2:1);

 writeln();

 writeln('---------------------------------');

 writeln('Задание 5');

 write('Введите n : ');

 readln(n);

  s:=0;

  for i:= 1 to n do

    s := s + i/2;

  writeln('Сумма ряда = ', s:2:1);

  if s>10 then

    writeln('Сумма ряда больше 10')

  else

    writeln('Сумма ряда меньше 10');

 writeln('---------------------------------');

 writeln('Задание 6');

 for i:=0 to k-1 do begin

   write('введите [', i, '] = ');

   readln(ar[i]);

 end;

 n:=0;

 for i:=0 to k-1 do

   if (ar[i] mod 2 = 0) then

     inc(n);

 writeln('Кол-во чётных чисел = ', n);

end.


Решите задачи в паскале
0,0(0 оценок)
Ответ:
тигра36
20.06.2020 09:56
Dim mas(,) As Integer
Dim u As Integer, u2 As Integer
Dim a As Integer
Dim b As Integer 

a = InputBox("Введите Начало промежутка (A)") 
b = InputBox("Введите Конец промежутка  (В)")
       
Dim Length As Integer 
Length = CInt(((b - a) ^ 2) ^ 0.5)   
ReDim mas(Length, 1)
       
Dim x As Integer, y As Integer, i As Integer       

For x = a To b
            mas(i, 0) = x
            i += 1
Next

For x = 0 To Length
            For i = 1 To mas(x, 0)
                If (mas(x, 0) Mod i) = 0 Then
                    mas(x, 1) += 1
                End If
            Next
Next

For i = Length To 0 Step -1
            For y = Length To 1 Step -1
                If mas(y, 1) > mas(y - 1, 1) Then
                    u = mas(y, 1)
                    u2 = mas(y, 0)
                    mas(y, 1) = mas(y - 1, 1)
                    mas(y, 0) = mas(y - 1, 0)

                    mas(y - 1, 1) = u
                    mas(y - 1, 0) = u2
                End If
            Next y
Next i

Например на промежутке 5 - 55 результат такой:
48 делителей 10
36 делителей 9
24 делителей 8
30 делителей 8
40 делителей 8
42 делителей 8
54 делителей 8
12 делителей 6
18 делителей 6
20 делителей 6
28 делителей 6
32 делителей 6
44 делителей 6
45 делителей 6
50 делителей 6
52 делителей 6
16 делителей 5
6 делителей 4
8 делителей 4
10 делителей 4
14 делителей 4
15 делителей 4
21 делителей 4
22 делителей 4
26 делителей 4
27 делителей 4
33 делителей 4
34 делителей 4
35 делителей 4
38 делителей 4
39 делителей 4
46 делителей 4
51 делителей 4
55 делителей 4
9 делителей 3
25 делителей 3
49 делителей 3
5 делителей 2
7 делителей 2
11 делителей 2
13 делителей 2
17 делителей 2
19 делителей 2
23 делителей 2
29 делителей 2
31 делителей 2
37 делителей 2
41 делителей 2
43 делителей 2
47 делителей 2
53 делителей 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота