opasno10
07.04.2023 09:20

Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила большее число то пользователь нажимает < если программа предложила меньшее число то пользователь нажимает > а если угадала то = тема циклы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tata20082
10.06.2020 19:51

var min,max,n:integer;
c:string;
Begin
    min:=1;
    max:=1000;
    repeat
        n:=(max+min) div 2;
        writeln(n);
        read(c);
        case c of
            ">": min:=n+1;
            "<": max:=n-1;
        end
    until (c="=");
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота