В массиве хранится информация об отметках 20 учащихся за контрольную работу (случайные числа от 1 до 10). Составьте программу, которая вычисляет количество учащихся, получивших неудовлетворительные отметки (0, 1, 2).
Лазерний принтер (англ. laser printer) — один з видів принтерів, що дозволяє швидко виготовляти високоякісні відбитки тексту і графіки на звичайному папері. Подібно до фотокопіювальних апаратівлазерні принтери використовують у процесі ксерографічного друку, однак відмінність полягає у тому, що формування зображення відбувається шляхом безпосередньої експозиції (освітлення) лазерним променем фоточутливих елементів принтера.
Принцип дії лазерного принтера полягає у наступному: на алюмінієву трубку (фотобарабан), покриту світлочутливим шаром, наноситься негативний статичний заряд. Після цього промінь лазера проходить по фотобарабану, і у тому місці, де потрібно щось надрукувати, знімає частину заряду. Після чого на фотобарабан наноситься тонер (це сухе чорнило, що складаються із суміші смол, полімерів, металевої стружки, вугільного пилу та іншої хімії), який також має негативний заряд, і тому прилипає до барабана у тих місцях, де пройшов лазер і зняв заряд. Далі барабан прокочується по паперу (що має позитивний заряд) і залишає на ньому весь тонер, після чого папір потрапляє у піч, де під впливом високої температури тонер міцно припікається до паперу.
Для друку кольорового зображення всі кольори на барабан наносяться по черзі, або друк відбувається у 4 проходи (для друку чорного, блакитного, пурпурного і жовтого кольорів). Подібний метод друку використовується в копіювальних апаратах і деяких факсах. Схожа система використовується і в світлодіодних принтерах, однак у них замість лазера використовується нерухомий рядок зі світлодіодами — LED-технологія друку (Light Emitting Diode). Росийська Лазерный принтер (англ. Laser printer) - один из видов принтеров, позволяющий быстро изготавливать высококачественные отпечатки текста и графики на обычной бумаге. Подобно фотокопировальных апаративлазерни принтеры используют в процессе ксерографического печати, однако отличие состоит в том, что формирование изображения происходит путем непосредственной экспозиции (освещение) лазерным лучом фоточувствительных элементов принтера.
Принцип действия лазерного принтера заключается в следующем: на алюминиевую трубку (фотобарабан), покрытую светочувствительным слоем, наносится отрицательный статический заряд. После этого луч лазера проходит по фотобарабана, и в том месте, где нужно что-то напечатать, снимает часть заряда. После чего на фотобарабан наносится тонер (это сухие чернила, состоящие из смеси смол, полимеров, металлической стружки, угольной пыли и другой химии), который также имеет отрицательный заряд, и поэтому прилипает к барабану в тех местах, где лазер и снял заряд . Далее барабан прокатывается по бумаге (имеющей положительный заряд) и оставляет на нем все тонер, после чего бумага попадает в печь, где под воздействием высокой температуры тонер прочно припекается к бумаге.
Для печати цветного изображения все цвета на барабан наносятся по очереди, или печать происходит в 4 прохода (для печати черного, голубого, пурпурного и желтого цветов). Подобный метод печати используется в копировальных аппаратах и некоторых факсах. Похожая система используется и в светодиодных принтерах, однако в них вместо лазера используется неподвижный строку со светодиодами - LED-технология печати (Light Emitting Diode).
var a: array[1..m, 1..n] of integer; i, j, t: integer; p: longint;
begin Randomize; Writeln('Исходный массив'); p := 1; for i := 1 to m do begin for j := 1 to n do begin a[i, j] := Random(19) - 9; Write(a[i, j]:3); if (abs(a[i, j]) < 1) or (abs(a[i, j]) > 5) then p := p * a[i, j] end; Writeln end; Writeln('Произведение элементов с модулем вне [1;5] равно ', p) end.
Тестовое решение: Исходный массив -8 2 7 -3 -8 5 1 -4 -3 6 9 6 Произведение элементов с модулем вне [1;5] равно 145152
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку