Mixachu
13.11.2021 04:21

Написать программу, которая после ввода пользователем трёхзначного числа вычисляет сумму его цифр.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Buivid1
24.05.2020 09:46

var a,a1,a2,a3 : integer;  

begin

  readln(a);

  a1:=a div 100;

  a2:=(a mod 100) div 10;

  a3:=(a mod 100) mod 10;

  writeln(a1+a2+a3);

end.

 а - само число, а1-число сотен, а2-число десятков, а3-число единиц

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота