asatuchina1502
27.03.2023 07:05

Нарисовать блок-схему и написать программу для решения задачи: запросить 3 числа. Определить, можно ли построить треугольник. Если да, то является он равнобедренным, равносторонним или разносторонним.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
BN6573
19.05.2022 00:22

ответ:«Компьютер» сөзі ағылшын тілінен аударғанда есептеуіш , есептеуге арналған құрылғы дегенді білдіреді. Компьютерлер есептеу операцияларының қатарларын адамның қатысуынсыз, алдын ала көрсетілген нұсқаулық – бағдарлама бойынша жүргізуге мүмкіндік береді. Есептеуіш техниканың қазіргі тарихының негізі 1943 жылы «Марк-1» машинасының дүниеге келуінен бастап қаланды. Компьютерлердің алдыңғы буындары шамдық есептеуіш машиналар болатын, олардың орнын транзисторлы электронды есептеуіш машиналар (ЭЕМ), содан кейін – интегралды сызбалар пайдаланылатын электронды есептеуіш машиналар және ең ақырында, қазіргі таңда аса үлкен интеграциялық деңгейлі сызбалар пайдаланылатын ЭЕМ басты.

Негізгі принциптері: Өзінің алдына қойылған тапсырманы орындау үшін компьютер механикалық бөліктердің орын ауыстырылуын, электрондардың, фотондардың, кванттық бөлшектердің ағынын немесе басқа да жақсы зерттелген физикалық құбылыс әсерлерін қолданады. Көбімізге компьютерлердің ең көп таралған түрі — дербес компьютер жақсы таныс.

Компьютер архитектурасы алға қойылған мәселені, зерттеліп отырған физикалық құбылысты максималды айқын көрсетіп, модельдеуге мүмкіндік береді. Мысалы, электрондық ағындар бөгеттер салу кезіндегі су ағынының үлгісі ретінде қолданылуы мүмкін. Осылай құрастырылған аналогтық компьютерлер XX ғасырдың 60-жылдары көп болғанымен, қазір сирек кездеседі.

Қазіргі заманғы компьютерлердің басым бөлігінде алға қойылған мәселе әуелі математикалық терминдерде сипатталады, бұл кезде барлық қажетті ақпарат екілік жүйеде (бір және ноль ретінде) көрсетіледі, содан кейін оны өңдеу үшін қарапайым логика алгебрасы қолданылады. Іс жүзінде барлық математикалық есептерді бульдік операциялар жиынына айналдыруға болатындықтан, жылдам жұмыс жасайтын электронды компьютерді математикалық есептердің, сонымен қатар, ақпаратты басқару есептерінің көпшілігін шешу үшін қолдануға болады.

Бірақ, компьютерлер кез келген математикалық есепті шеше алмайды. Компьютер шеше алмайтын есептерді ағылшын математигі Алан Тьюринг сипаттаған болатын.

Орындалған есеп нәтижесі пайдаланушыға әр түрлі енгізу-шығару құрылғыларының көмегімен көрсетіледі, мысалы, лампалық индикаторлар, мониторлар, принтерлер және т.б.

Компьютер — жай ғана машина, ол өзі көрсетіп тұрған сөздерді «түсінбейді» және өз бетінше «ойламайды». Компьютер тек қана бағдарламада көрсетілген сызықтар мен түстерді енгізу-шығару құрылғыларының көмегімен механикалық түрде көрсетеді. Адам миы экрандағы көріністі қабылдап, оған белгілі бір мән береді.

Объяснение:

0,0(0 оценок)
Ответ:
abdulla805
24.04.2022 03:27
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var c:=ReadlnChar('Буква:');
  Writeln('Буква встречается ',s.Where(p->p=c).Count,' раз(а)')
end.

Пример
Текст: а роза упала на лапу азора
Буква: а
Буква встречается 8 раз(а)

// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var m:=s.MatchValues('(\w)\1{1}').Distinct;
  foreach var cc in m do s:=s.Replace(cc,cc[1]);
  s.Println
end.

Пример
Текст: стеклянный оловянный длинношеее искусство
стекляный оловяный длиношее искуство
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота