michukdblack
20.08.2022 05:47

Код на Pascal ABC Дан набор из N отрезков различной длины. Сколькими можно выбрать из этих отрезков три, из которых можно составить (невырожденный) треугольник?
Входные данные
Сначала вводится количество отрезков, затем длины этих отрезков (еще N чисел).
Выходные данные
Программа должна вывести одно число - искомое количество
Количество отрезков - не менее 3 и не более 20. Длина каждого отрезка - натуральное число, не превосходящее 1000. Все отрезки имеют разную длину.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
melesineduard
22.02.2023 15:26

1) Браузер

2) Таблица

3) 2 ( обновить ссылку на странице, которая будет вести на новую страницу n, и на самой странице n)

4) Графически представлять данные с графиков и диаграмм, выводить на печать электронные таблицы; вычислять и анализировать данные, а также пересчитывать значения при изменении данных; создавать, открывать, редактировать, а также сохранять таблицы в файле

5)Название документа, название программы и кнопки управления окном

6)Числовые данные

7)Один столбец с числами

8)Параметры диаграммы, тип и вид диаграммы и источник данных диаграмм

Все ответы проверены

0,0(0 оценок)
Ответ:
scfsdfddPenis
25.01.2022 04:07

Код:

using System;namespace ThisAnswerIsNotMine {    class Program    {        private static int a;        private static int b;        private static int c;        private static int d;        private static void Main()        {            int.TryParse(Console.ReadLine()!, out a);            int.TryParse(Console.ReadLine()!, out b);            int.TryParse(Console.ReadLine()!, out c);            int.TryParse(Console.ReadLine()!, out d);                        Console.WriteLine((a / c) * (b / d) >= (b / c) * (a / d) ? "Широкая" : "Узкая");        }    }}
Написать на С# Имеется стол прямоугольной формы размером а х b (а и b — целые числа, а > b). В ка
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота