Ариана16112001
08.01.2020 02:44

Написать программу с функции-генератора (yield), которая считает факториал введённого числа. Python​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katenabelozerova
06.03.2023 16:06
А) не ( A или не В и С ) упрощаем выражение и получаем
not(a) and (b or not(c))

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=not(a) and (b or not(c))
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)

б) А и не ( В и или не С) получим такое выражение:
a and (b or not(c))

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=a and (b or not(c))
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)


в) не ( не А или В и С)  преобразуем:
a and (b or c)

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=a and (b or c)
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)
0,0(0 оценок)
Ответ:
Ikramhaus221
08.05.2021 14:45
1. Для цикла For

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  for i := 1 to N do
    p:=p*x;
  writeln(x,' в степени ',n,' равно ',p );
end.

2. Для цикла While
var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  while i<=n do begin
    p:=p*x;
    i:=i+1;
  end;
  writeln(x,' в степени ',n,' равно ',p );
end.

3. Для цикла Repeat

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  repeat
    p:=p*x;
    i:=i+1;
  until i>n;
  writeln(x,' в степени ',n,' равно ',p );
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота