karolinaivanova10
04.01.2022 05:36

Составить программу вычисления следующих функций знак(Ɐ - обозначает "для любых")


Составить программу вычисления следующих функций знак(Ɐ - обозначает для любых)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Флов227монстр
29.06.2022 09:44
Program p1;
var
  a:array[1..7,1..7] of byte;
  i,j:byte;
begin
  for i:=1 to 7 do
  begin
    for j:=1 to 7 do
    begin
    if i<=4 then
      if (j>=i) and (j<=8-i) then a[i,j]:=1 else a[i,j]:=0
    else
      if (j<=i) and (j>=8-i) then a[i,j]:=1 else a[i,j]:=0;
    Write(a[i,j]:2)
    end;
  Writeln
  end
end.

Результат выполнения программы:
 1 1 1 1 1 1 1
 0 1 1 1 1 1 0
 0 0 1 1 1 0 0
 0 0 0 1 0 0 0
 0 0 1 1 1 0 0
 0 1 1 1 1 1 0
 1 1 1 1 1 1 1

program p2;
var
  a:array[1..6,1..6] of byte;
  i,j:byte;
begin
  for i:=1 to 6 do
  begin
    for j:=1 to 6 do
    begin
    a[i,j]:=i+j-1;
    if a[i,j]>6 then a[i,j]:=a[i,j]-6;
    Write(a[i,j]:2)
    end;
  Writeln
  end
end.

Результат выполнения программы:
 1 2 3 4 5 6
 2 3 4 5 6 1
 3 4 5 6 1 2
 4 5 6 1 2 3
 5 6 1 2 3 4
 6 1 2 3 4 5
0,0(0 оценок)
Ответ:
mahamde
23.04.2022 23:39

//Массив b сделан таким большим из-за возможности, что в массиве a будут все положительные, а разместить надо на чётных. Есть возможность сделать через динамический массив.

const  

 n=40;

var

 a:array [1..n] of integer;

 b:array [0..2*n-1] of integer;

 i,j,sum:integer;

begin

 randomize;

 sum:=0;

 j:=0;

 for i:=1 to n do

   begin

     a[i]:=random(21)-10;

     if a[i]>0 then

       begin

         b[j]:=a[i];

         j:=j+2;

         sum:=sum+sqr(a[i]);

       end;

     write(a[i]:4);

   end;

 writeln;

 writeln;

 for i:=0 to 2*n-1 do

   write(b[i]:4);

 writeln;

 writeln('Sum: ',sum);  

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота