C++ Напишите программу на c++, которая заполняет квадратную матрицу 4х4 случайными числами в интервале [10,99], и находит максимальный и минимальный элементы в матрице и их индексы
Программу надо сформатировать и тогда её структура будет видна лучше. А чтобы понять, как идет выполнение, в нужных точках ставим промежуточную выдачу - это называется "трассировкой".
var s, k: integer; label met; begin s:=-12; k:=90; Writeln('s=',s,', k=',k); s:=s+10; Writeln('s=',s); met: Writeln('Метка met:'); k:=k+10; Write('k=',k); if k<200 then s:=50 else s:=s+k; Writeln(', s=',s); if k<200 then goto met; Writeln('Результат: s=',s) end.
№ 1 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) неверно, что 0 < X ≤ 3 и Y>5; 2) X является max(X,Y); 3) X не является min(X,Y); 4) Z является min(X,Y,Z). № 2 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) Y не является max(X,Y,Z) и не является min(X,Y,Z); 2) X,Y,Z равны между собой; 3) каждое из чисел X,Y,Z положительно; 4) каждое из чисел X,Y,Z отрицательно.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку