BafuDzn
17.06.2021 23:49

написать программу для С++ Дан массив из n элементов. Найти сумму элементов, стоящих на нечетных
местах и вывести их на экран. Затем вставить их в новый массив умножив на
n, и удалить последний элемент.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vavelichTabak
17.12.2020 08:18

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

using namespace std;

int main() {

vector<int> arr;

int n;

cout << "n: ";

cin >> n;

srand(time(0));

long long sum = 0;

vector<long int> multi;

for(int i = 0; i<10; ++i) { //  тут поменять чтобы изменить колво чисел

arr.push_back(rand());

if(i%2!=0) {

sum+=arr[arr.size()-1];

cout << arr[i] << " ";

multi.push_back(arr[arr.size()-1]*n);

}

}

cout << endl << "Multi: ";

for(int i = 0; i<multi.size(); ++i) {

cout << multi[i] << " ";

}

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота