MARI5368334
17.06.2020 03:03

Выведите все элементы массива с: а) нечётными индексами (то есть A[1], A[3], A[5], ...);

б) чётными индексами (то есть A[0], A[2], A[4], ...).

Формат входных данных

Вводится количество элементов в массиве. Далее вводятся элементы массива.

Формат выходных данных

Выведите ответ на задачу.

Sample Input:

5

1

2

3

4

5

Sample Output:

1 3 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alinaosipyants
22.12.2020 23:42

int[] mas;

int n;  

n = Convert.ToInt32(Console.ReadLine());

mas = new int[n];

for (int i = 0; i < mas.Length; i++)

mas[i] = Convert.ToInt32(Console.ReadLine());

Console.WriteLine();

Console.WriteLine("Элементы с чётными индексами:");

for (int i = 0; i < mas.Length; i = i + 2)

{    

Console.WriteLine(mas[i]);

}

Console.WriteLine();

Console.WriteLine("Элементы с нечётными индексами:");

for (int i = 1; i < mas.Length; i = i + 2)

{

Console.WriteLine(mas[i]);

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота