Уляна2000002
17.07.2020 14:50

Дано трёхзначное число. Напишите программу на языке Паскаль, которые определяют: 1) является ли суммы его цифр двухзначным числом; 2) является ли произведение его цифр трехзначным числом; 3) больше ли это число произведение его цифр; 4) кратно ли пяти сумма его цифр; 5) кратно ли сумме его цифр на это число?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
erik09hfilya
09.01.2020 20:06
1.                                        

program raf105;

var abc,a,b,c: integer;

begin

write('Введите трёхзначное число: ');

readln(abc);

a:= abc div 100;

b:= (abc div 10) mod 10;

c:= abc mod 10;

abc:= c*100 + b*10 + a;

writeln('Число наоборот: ',abc);

end.

2.                                        

program raf105;

var abc,a,b,c: integer;

begin

write('Введите трёхзначное число: ');

readln(abc);

a:= abc div 100;

b:= (abc div 10) mod 10;

c:= abc mod 10;

abc:= b*100 + c*10 + a;

writeln('Первое число переместили в конец: ',abc);

end.

                                         PascalABC 3.4.2
0,0(0 оценок)
Ответ:
Ротср
13.03.2023 07:15

pascal

Объяснение:

program photo;

var

 a, b: integer;

begin

 WriteLn('Введите размер фотографии в см: ');

 Write('длина: '); ReadLn(a);

 Write('ширина: '); ReadLn(b);

 WriteLn('Размер отсканированного изображения разрешением 600 пиксел/дюйм');

 WriteLn('при 24-битном кодировании будет равен:');

 WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24:12:2, ' бит');

 WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24 / 8:12:2, ' байт');  

 WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24 / 8 / 1024:12:2, ' Кбайт');  

 WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24 / 8 / 1024 / 1024:12:2, ' Мбайт');  

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота