ЛилияЕршова
12.10.2022 08:27

Напишите программу, которая выделяет в другой массив все элементы исходного массива, которые записываются трёхзначными числами в десятичной системе, делятся на K и не делятся на M . Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . В третьей строке через пробел записаны два числа – K ( 1 < K ≤ N ) и M ( 1 ≤ M ≤ N ).

Выходные данные
Программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами. Если ни одного подходящего элемента в массиве не было, программа должна вывести число 0.
НА С++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vanea228
28.12.2020 16:07

Объяснение:

Pascal

program pr;

 

var

 i, n, k, cout: integer;

 a, b: array [1..100] of integer;

 

begin

 cout := 0;

 k := 1;

 writeln('Введите размер массива');

 readln(n);

 if (n>0) and (n<=10000) then  

 begin

 for i := 1 to n do

 begin

   read(a[i]);

 end;

 writeln;

 for i := 1 to n do

   if a[i] < 0 then

   begin

     cout := cout + 1;

     b[k] := a[i];

     k := k + 1;

   end;

 if cout = 0 then

   writeln(0) else  

   for k := 1 to cout do

     write(b[k]:3);

     end

     else writeln('Не корректный ввод n');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота