FireLily
30.01.2023 14:22

Используя функции, написать программу с нижеследующей функциональностью. Пользователь вводит с клавиатуры диаметры 5-ти окружностей. Посчитать площадь и периметр каждой окружности. Вывести данные по каждой окружности на экран. Для расчёта периметра и площади окружности использовать две отдельные функции: одну для периметра, другую для площади. Так же, использовать функции для ввода радиуса окружности и для вывода результатов расчёта.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
diduh2002
17.05.2022 15:36
Flash-память представляет собой микросхему, помещенную в миниатюрный плоский корпус. Для считывания или записи информации карта памяти вставляется в специальные накопители, встроенные в мобильные устройства или подключаемые к компьютеру через USB-порт. Информационная емкость карт памяти может достигать 512 Мбайт.К недостаткам flash-памяти следует отнести то, что не существует единого стандарта и различные производители изготавливают несовместимые друг с другом по размерам и электрическим параметрам карты памяти.
0,0(0 оценок)
Ответ:
24556
26.07.2021 02:48

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

#include <stdio.h>

#include <math.h>

#include <string.h>

#include <iostream>

int main(void) {

   struct NOTE {

       char name[100];

       char family[100];

       int tele[15];

   };

   

   struct NOTE note[5];

   

   int i;

   

   

   

   for(i=0;i<5;i++) {

       printf("note %d:\n",i);

       printf("name?: "); scanf("%s",&note[i].name);

       printf("family?: "); scanf("%s",&note[i].family);

       printf("telephone?: "); scanf("%d",&note[i].tele);

   }

   int z[15];

   printf("telephone: ");scanf("%d",z[]);

   for(i=0;i<5;i++)

       if (strcmp(note[i].tele,z)==0){ //<ТУТ СЦУКА РУГАЕТСЯ,НЕ ПОЙМУ ПОЧЕМУ ХЛП

           printf("name: %s\n family %s\n telephone %d\n",note[i].name,note[i].family,note[i].tele);

       }

   char t[40];

   printf("name: "); scanf("%s",t);

   for(i=0;i<5;i++)

       if (strcmp(note[i].name,t)==0){

           printf("name: %s\n family %s\n telephone %d\n",note[i].name,note[i].family,note[i].tele);

       }

   

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота