matveysandors
18.08.2022 08:49

Составьте программу вычисления корней квадратного уравнения aх^2+вх+с=0 по данным значениям его коэффициентов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Никиланджело
12.06.2020 14:46
Var a, b, c, d, x1, x2 : real; \\ задание переменных действительных чисел.

begin 
write('a = '); readln(a);     \\запрос у пользователя первого коэффициента
write('b = '); readln(b);     \\запрос у пользователя второго коэффициента
write('c = '); readln(c);    \\запрос у пользователя третьего коэффициента
d := b*b - 4*a*c;             \\ расчет дискриминанта
if d=0 then                 \\ветка для решения при нулевом дискриминанте
begin 
x1 := b / (2 * a) 
writeln (x1:3:3); 
end                      \\ окончание при нулевом дискриминанте
else 
if d>0 then       \\ ветка для решения при положительном дискриминанте
begin 
x1 := (- b + sqrt(d) / (2 * a);    \\ первый корень
x2 := (- b - sqrt(d) / (2 * a);      \\ второй корень
writeln (x1:3:3, ' ', x2:3:3);     \\ вывод ответа
end 
else                  \\ ветка решения для отрицательного дискриминанта
writeln ('Нет действительных корней'); 
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота